Mobile Media Converter

julio 31, 2007

Hace unos dias grabe unos videos con mi celular, el problema es que se graban en formato .3gp y yo queria pasarlos a formato .mpeg

Cuando usaba windows usaba el Mobile Media Converter, pense que este programa era solo para windows pero tambien tiene una version para Linux. Primero deberas descargar ESTE paquete.

El programa no necesita instalacion, solo debes descomprimir el paquete y darle permisos de ejecucion a los archivos que contiene. El paquete contiene 2 archivos el ffmpeg y el Mobile Media Converter Te recomiendo crear un directorio nuevo en el direcotrio /opt que se llama mmc y renombrar el Mobile Media Converter a mmc Despues de esto abre el gedit y escribe el siguiente codigo y guardalo como mmc.desktop en el directorio /usr/share/aplications

[Desktop Entry]
Encoding=UTF-8
Name=Mobile Media Converter
Type=Application
Categories=Application;AudioVideo;Multimedia;
Icon=/usr/share/icons/Human/22×22/categories/applications-multimedia.png
Exec=/opt/mmc/mmc
Terminal=false

El icono se lo puedes cambiar, solo elige un icono que te guste y escribe la ruta donde dice icon 馃槈

Con esto tendremos el Mobile Media Converter en orden, con su respectivo lanzador en el menu y podremos convertir nuetros videos.

Anuncios

Problemas al compilar cinelerra

julio 31, 2007

Me he dado por vencido, pues al tratar de instalar cinelerra me he topado con muchos problemas, y despues de solucionar 2 y ver que se me venian mas lo deje por la paz.

El primer error que se me presento fue al ejecutar el script “configure” y el error fue el siguiente:

[: 24: ==: unexpected operator
[: 31: ==: unexpected operator
./configure: 47: Syntax error: Bad fd number

Busque y en un foro en ingles sugieren usar “bash” antes de ejecutar el script, algo asi como”bash ./configure” Esto soluciona el problema y te sale el siguiente mensaje, basicamente que dos depencias no se satisfacen:

*** Nasm is required. Download it from nasm.sourceforge.net
*** Yasm is required. Download it from http://www.tortall.net/projects/yasm/

Pues ya, ahi voy y que las instalo… y otra vez a ejecutar el script y aparece el siguiente chorizote:

CONFIGURING QUICKTIME
[: 22: ==: unexpected operator
[: 27: ==: unexpected operator
./configure: 39: Syntax error: Bad fd number
CONFIGURING LIBMPEG3
./configure: line 139: cd: libmpeg3*: No existe el fichero 贸 directorio
CONFIGURING FFTW
./configure: line 142: cd: fftw*: No existe el fichero 贸 directorio
CONFIGURING MJPEGTOOLS
./configure: line 145: cd: mjpegtools*: No existe el fichero 贸 directorio
CONFIGURING SNDFILE
./configure: line 150: cd: libsndfile*: No existe el fichero 贸 directorio
CONFIGURING RAW1394
./configure: line 153: cd: libraw1394*: No existe el fichero 贸 directorio
CONFIGURING AVC1394
./configure: line 159: cd: libavc1394*: No existe el fichero 贸 directorio
CONFIGURING IEC61883
./configure: line 165: cd: libiec61883*: No existe el fichero 贸 directorio
CONFIGURING THEORA
./configure: line 173: cd: libtheora*: No existe el fichero 贸 directorio
Writing hvirtual_config.h
Have Video4Linux 2
Have DVB
Have OpenGL 2.0
Configured successfully. Type ‘make’ to build it.
bbto@bbto:~/descargas/cinelerra-2.1$ sudo make
make -f build/Makefile.cinelerra
sh: Syntax error: end of file unexpected (expecting “then”)
make[1]: se ingresa al directorio `/home/bbto/descargas/cinelerra-2.1′
gcc -c -O2 -fomit-frame-pointer -falign-loops=2 -falign-jumps=2 -falign-functions=2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -I../../freetype-2.1.4/include -I../../ -DHAVE_OSS -DHAVE_FIREWIRE soundtest.c -o i686/soundtest.o
Assembler messages:
Fatal error: can’t create i686/soundtest.o: No such file or directory
make[1]: *** [i686/soundtest.o] Error 1
make[1]: se sale del directorio `/home/bbto/descargas/cinelerra-2.1′
make: *** [all] Error 2

En resumen, todavia me faltan muchas depencias y el ultimo error se soluciona creando el directorio i686 en el sistema de archivos, en fin, no me hace mucha falta el cinelerra, solo lo queria probar, y no queria agregar otra linea a mi sources.list y decidi compilar, si tu tambien estas en las mismas te sugiero modifiques su sources.list para evitar compilar, solo debes escoger en la siguiente lista tu version de ubuntu, tu tipo de procesador y agregar la linea correspondiente a tu sources.list

Ubuntu 7.04 Feisty Fawn:

i386 thnks to muzzol

deb http://www.kiberpipa.org/~muzzol/cinelerra/feisty-i386/ ./

AMD64 thnks to Valentina MESSERI

deb http://giss.tv/~vale/ubuntu64 ./

i686 thnks to Jure CUHALEV

deb http://www.kiberpipa.org/~gandalf/ubuntu/feisty/cinelerra/i686/ ./

athlonxp thnks to Jure CUHALEV

deb http://www.kiberpipa.org/~gandalf/ubuntu/feisty/cinelerra/athlonxp/ ./

pentium4 thnks to Jure CUHALEV

deb http://www.kiberpipa.org/~gandalf/ubuntu/feisty/cinelerra/pentium4/ ./

Ubuntu 6.10 Edgy Eft

i386 thnks to muzzol

deb http://www.kiberpipa.org/~muzzol/cinelerra/edgy-i386/ ./

Ubuntu 6.06 Dapper Drake

pentium4 thnks to Jure CUHALEV

deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/pentium4/ ./

i686 thnks to Jure CUHALEV

deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/i686/ ./

athlonxp thnks to Jure CUHALEV

deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/athlonxp/ ./

Pagina oficial de cinelerra. (en ingles)

Manual de cinelerra. (muy util, en ingles)


I Love Elisa!

julio 27, 2007

No se como no tuve el placer de conocerla antes. Es que es simplemente encanatadora. Tengo que confesar que me he enamorado. No, no estoy hablando de una chiquilla, estoy hablando de Elisa Media Center.

Elisa media center te permite organizar tus fotos, videos, musica, reproducir DVDs y muchas cosas mas, dentro de una bonita interfaz que puede ser personalizada con temas y plugins.

Para que les digo mas, mejor vean este video:

Ahora lo quieres instalar verdad? lo sabia…

Bien, si usas Feisty como yo debes hacer lo siguiente. Primero debes editar tu sources.list que se encuentra en el directorio /etc/apt Debes agregarla las siguientes lineas:

#ELISA MEDIA CENTER STARTdeb http://elisa.fluendo.com/packages feisty main

#ELISA MEDIA CENTER END

Luego debes actualizar tu sources.list con el comando “sudo apt-get update” Ahora ya podemos instalarlo, solo teclear “sudo apt-get install” elisa Con esto deberias estar disfrutando de Elisa.

Si usas Edgy la linea que debes agregar a tu sources.list es:

deb http://elisa.fluendo.com/packages edgy main

Sigues el procedimiento anterior y listo, a agasajarnos con Elisa.


Mupen 64

julio 26, 2007

mupen64_icon.png

Mupen 64 es un emulador mas para linux, aunque tambien existe su version para winbugs. Para tener Mupen 64 en tu sistema solo necesitas bajar el archivo fuente. Ya que lo has descargado deberas descomprimirlo, con esto, mupen64 esta listo para ejecutarse, no es necesario compilarlo ni nada por estilo.

Pero no querras tener el emulador en tu carpata personal, asi que el directorio ideal para guardarlo es el /opt En este directorio se guardan algunos programas que tienen muchos archivos o subdirectorios y no se quiere que esten “desparramados”. Solo debes mover el archivo descomprimido a ese directorio y el archivo “mupen64_icon.png” deberas moverlo a /usr/share/pixmaps.

Ahora abre el gedit que vamos a hacer el acceso directo para el menu de gnome. Copia y pega lo siguiente y guardalo como mupen64.desktop en el directorio /usr/share/applications

[Desktop Entry]
Encoding=UTF-8
Name=Mupen64
Comment=Emulador para nintendo 64.
Type=Application
Categories=Application;Game
Icon=/usr/share/pixmaps/mupen64_icon.png
Exec=/opt/mupen64-0.5/mupen64
Terminal=false

Una vez que lo tengas corriendo deberas configurarlo. Ve a “configure” y da click en la pesta帽a de plugins. En el plugin de gfx, los que funcionan mejor son los 3, 4 y 5. Si alguno no te funciona bien prueba con otro, igual que con los plugins de audio.

 


Neo-Geo en ubuntu. Gngeo y Xgngeo.

julio 20, 2007

xgngeo.jpggngeo_logo.png

Por fin lo logre. Ya tengo instalado mi emulador de Neo-Geo en ubuntu. He instaldo el Gngeo y su interfaz grafica el Xgngeo. Estos dos se instalan por separado y hay que compilarlos.

  • Lo primero que debes hacer es bajar ESTE archivo y descomprimirlo.
  • Abre la terminal, con el comando “cd” navega hasta la carpeta descomprimida.
  • Ejecuta el siguiente comando: ./configure.
    • Si te sale el error: configure: error: installation or configuration problem: C compiler cannot create executables. Instala el “build essential”, desde synaptic o la terminal.
    • Si te sale el error: “error: can’t find zlib on your system” Instala “zlib1g-dev” y “zlibc”
    • Si te sale el error: “configure: error: can’t find sdl-config on your system” Instala “libsdl1.2-dev”
  • Ahi mismo en la terminal escribe “make” y presiona entar.
  • Escribe “sudo make install” y presiona enter.
  • Hasta Aqui ya deberias tener instalado el emulado Gngeo. Congrats!
  • Para instalar la interfaz grafica descarga ESTE archivo.
  • Descomprimelo y navega desde la terminal hasta el.
  • Ejecuta el siguieten comando “python setup.py install”
  • Hasta aqui deberias tener instalado el emulador y la interfaz grafica. one more time, Congrats!
  • Ahora deberas descargar el Bios de neo-geo. En esta pagina encontraras links para descargarlo.
  • Si no tienes todo lo anterior el ejecutar el xgngeo desde Aplicaciones > Juegos > Xgngeo te pedira que espefiques las rutas faltantes. En la que mas se presentan errores es en la del Bios. Revisa que la ruta lleve a una carpeta con el Bios que has descargado.

Problemas con GCC

julio 19, 2007

gcc_logo.png

Para los que no sepan, GCC es un conjunto de compiladores creados por el proyecto GNU. Hace unos dias me anime a compilar un paquete pero me tope con un error que por lo visto es bastante comun.

Al compilar hay que ejecutar algunos comandos desde la terminal y algunos scripts de uno de ellos es “configure”

Bueno, el chiste es que al ejecutar dicho script me salia el siguiente error:

configure: error: installation or configuration problem: C compiler cannot create executables.

La solucion es muy sencilla, solo debemos instarlar el “build essential”. Se puede instalar desde la terminal o desde synaptic. Con esto al ejecutar ./configure no nos saldra ningun error y podremos compilar sin problemas. Compilar no es dificil, asi que si necesitan compilar algun paquete animense a hacerlo.


Ubuntu para novatos no firmara acuerdos con Microsoft.

julio 18, 2007

Ubuntu Para novatos Statement About Microsoft.

Comunicado de Prensa de ubuntu para novatos sobre Microsoft.

Catemaco, Veracruz. Mexico – Miercoles, Julio 18, 2007 – Ubuntu para novatos.

Despu茅s de los constantes rumores que la prensa ha generado sobre la posibilidad de que 鈥淯buntu para novatos鈥 o su creador BBto firmar谩 un acuerdo con Microsoft al igual que lo ah echo Novell, Xandros, o Linspire, me veo en la necesidad de hacer este comunicado oficial:
Ubuntu Para Novatos y su responsable y cualquier otro trabajo u obra del mismo autor no tienen ni tendran NUNCA llegaran a un acuerdo o relacion con Microsoft. Ubuntu Para Novatos y la mente detras del blog se unen unicamente y exclusivamente a inicitiavas de entidades libres.

Con esto se dan por terminados los rumores de supuestas reuniones y acuerdos con los creadores de Winbugs, aunque esto suponga un duro golpe para ellos.

El anterior comunicado de prensa forma parte de una campa帽a empezada por mi cuate Irando, en la cual tu tambien estas invitado a participar. Solo debes escribir un comunicado como este y formar una cadena de “compa帽ias” afiliadas a este movimiento por libertad. La cadena se formara poniedo al final del comunicado las webs afiliadas al movimiento. Por el momento son las siguientes:

Irando.Net

Ubuntu Para novatos.

Esta pendiente porque pronto habra un logo oficial para esta cadena de comunicados.